Start a new topic

The flutter plugin uses a deprecated version of the Android embedding

Wikitude 9.10

Flutter 2.5.3


`flutter pub get` to install the dependencies and link the Wikitude Plugin throws following error:


The plugin `augmented_reality_plugin_wikitude` uses a deprecated version of the

Android embedding.

To avoid unexpected runtime failures, or future build failures, try to see if

this plugin supports the Android V2 embedding. Otherwise, consider removing it

since a future release of Flutter will remove these deprecated APIs.

If you are plugin author, take a look at the docs for migrating the plugin to

the V2 embedding: https://flutter.dev/go/android-plugin-migration.


1 person has this problem

Hi,


we understand you're waiting for a release update. With the integration process into a large cooperation in general being complex (changes in processes and setup in almost all processes touching the development and release of the SDK) and the fact that releasing the Wikitude SDK means approval and QA for 17 packages this process took more time than anticipated.


We're in final approval steps for being able to release our upcoming Wikitude SDK in the 1-2 upcoming weeks. We will update you as soon as the version is ready to download and we're back to our original service quality.


Please stay tuned.


Thx Nicola



Hello, I hope this email finds you well! First of all, we would like to thank you for the great work you have done so far; the service you have provided is extremely powerful and its image recognition is exceptional.


However, we have to ask, is this project abandoned? From the view of our organization we have unfortunately felt this, as it has been almost a year since there has been an update to the Flutter plugin, and it is incompatible with the new plugin import methodology which makes it incompatible with many others. We are aware that the production of this patch has been delayed, but even if it is published, we are wondering if it will possibly become obsolete again due to other/future Flutter updates?

As such, from our point of view, we feel like it is somewhat dangerous to have you as partners. We would therefore like to know if this is a one-time event due to unforeseen circumstances, or is it Qualcomm's new policy - that this project has decreased in importance (or maybe even abandoned), and any future updates, when needed, will not be released on time?


Thank you!


Warmest regards,


1 person likes this

any updates on this? We would also need it


When might you at any point say that a seaward advancement group is a decent set-up for your undertaking, and that you ought to employ seaward engineers who will be advantageous for your association? There are various reasons regarding the reason why a seaward programming engineers is the most ideal choice for yourself as well as your organization. A seaward advancement group can bring a plenty of advantages and seaward programming engineers can be a colossal resource for your group. However, beside the advantages to be had while working with committed seaward groups, another fundamental component are our needs or goals while considering seaward improvement groups chipping away at seaward programming advancement projects. The needs that you have dealing with an undertaking can be your vital determinant in choosing whether or not to enlist seaward designers for your venture>> hire offshore development team

Nice article

What about release 9.11, why you go directly to 9.12 from 9.10?

Maybe you can release 9.11 and fix some issues.

This you are saying from NOVEMBER!


2 people like this

We are in the process of releasing 9.12.0. The process in taking much longer than what we expected but soon there will a new version available. 


Best regards,

Aitor.

Something new??

Hi,

Any updates on the migration?


2 people like this

Hi,


We expect to release a new version in the next few weeks. I would say February, but can't assure you.


Regards,

Aitor.

Any movements on this?

Dear Gregor,


The feature that you're requesting is included in our upcoming SDK release. As our release process changed now that we're part of the Qualcomm family, we unfortunately can't provide you with an exact timeline when the release will be publicly available. We'll add you to our list of customers to inform once the release is out. Sorry for the inconvenience.


Best regards,

Aitor.

Hi, we would like to use the plugin in a flutter 2.5 project with a deadline next week. Can you plz release this asap?
Or maybe publish a branch with the hotfix?

Regards
Gregor

Login or Signup to post a comment