Start a new topic

Real World Size

I have set the real world size of all my objects properly in Wikitude studio, one is 400mm and the other 2 are around 70mm. 

But when I bring them into Unity, they are all about the same size when I look at the point cloud preview. How do I get the point cloud in Unity to reflect the size set in Studio? Why can't I simply adjust the size in Unity?


Two things could be the case here:

  • Did you save your changes in Studio before downloading?
  • If you replace the target collection file in StreamingAssets, it could be that the Object Trackable still uses a cached version. To ensure that this is not happening, you could try to rename the target collection and see if the point cloud is the desired size.

Kind regards,


I tried both those things, it's still not working, also my point clouds are all rotated 90 degrees, which I have also confirmed is not the case in Studio. In addition none of the objects are actually tracking/detecting in AR on the build. I am very frustrated by this process! Every step of the way there have been issues.

Do you have any idea why the real world sizes aren't coming through, why they are rotated strangely, and why they aren't being detected in AR?

I am using Unity expert edition btw

(194 KB)

I have now tried creating a completely new project from scratch and it's still the same issue! This is obviously not happening in Unity, it is baked into the file, or the SDK is reading the file incorrectly. I have double checked inside each point cloud in studio and none of them are rotated. I have double checked the real world sizes as well. And all of them are saved. THIS SUCKS

Hi Edwon,

the rotation issue was fixed with the Wikitude Unity SDK versions 9.7.1.

The physical size value of the object target in Wikitude Studio should be set to 1. That ensures that the grid size in Studio is 1x1m. After scaling the point cloud itself afterwards, the correct size should be visible also in Unity.

Kind regards,

Login or Signup to post a comment