Start a new topic

Point Cloud Preview Error

I've added a custom wto to my project and when I try to preview the point cloud data the particle system appears unfrozen. It only displays the point cloud for a split sceond after I change the size of the points. Is there any way to fix this?

Hi Matt,

Previously we had the same issue with some third party Unity Editor packages... We aren't sure which packages are causing this, but the problem is that some packages apparently iterate over GameObjects in the scene during edit mode, which un-freezes a hidden particle system we are using for the point cloud visualization. Would you mind sharing a list of the non-default packages you are using?

Kind regards,


Hi Gökhan,
The only packages i'm using came preinstalled with unity 2019.4.16f1 and are all made by unity so i'd imagine they're all default packages.
Thansks for your help.

I added all of them, but it's still not unfreezing for me.... Do you mind sending your project over to

Kind regards,


I have the same problem... The same project seems fine on another pc. I think it occured when I update the graphic card drivers. Is it possible causing the particle preview error ? (i use unity 2020.3)


I'm afraid we were still not able to reproduce the issue on our end. I assume you're using Windows and not macOS, right? Does this issue occur all the time, or are there some specific actions that trigger it? Are you using the latest version of the Wikitude SDK?

Best regards,


Login or Signup to post a comment