Start a new topic

Undefined symbols while building in Xcode


Im using v9.5.0 of the Cordova extension and I'm trying to build to an iOS Simulator, using XCode v12.4 and when trying too build for x86_64 (as specified in the documentation) I get these errors:

Undefined symbol: _OBJC_CLASS_$_WTArchitectStartupConfiguration

Undefined symbol: _OBJC_CLASS_$_WTArchitectView

Undefined symbol: _OBJC_CLASS_$_WTAuthorizationRequestManager

Undefined symbol: _kWTScreenshotSaveModeKey

Undefined symbol: _kWTScreenshotBundleDirectoryKey

Undefined symbol: _kWTUnauthorizedAppleiOSSDKAPIsKey

(See attached screenshot)

I'm quite new to building for iOS and using XCode (the Android build is fine...) and I'm missing a step-by-step setup guide how to build for iOS on Xcode using the Cordova extension, so may be I'm overseeing some beginner faults...

Hi Jasper,

Maybe this forum post can help you with your issue.



Hi Eva,

Thank for your quick response! I did already try that, but in my folder 'WikitudeSDK.framework', there is no WikitudeSDK file. Instead there are a WikitudeSDK-x86_64 and WikitudeSDK-arm64 file. These can't be thinned since they're not fat. Deleting one of the two didn't help.

I've solved this issue by creating a new Cordova project on the Mac and adding the ios-platform and wikitude plugin. This solved the issue. (The Cordova project I created on a Windows-machine in exactly the same way led to the error mentioned above on the Mac)


Login or Signup to post a comment