Start a new topic

Getting Started with Xamarin.Wikitude

Getting Started with Xamarin.Wikitude

Dear all,

I'm currently trying to get started with the Wikitude / Xamarin combination. As the samples are not compiling on my rig, I'm trying to set up the image recognition exmaple by myself. However, I'm failing badly in regards to loading the world.

As far as I understood it, I should be able to load the world by using "architectView.Load("file to my index.html within the Assets folder"). However, my application is just crashing immediately after trying.


Additionally ,is there any good documentation mentioning how I can include? I have my base "ArchitectView" but I can not find answer how to go further.


Does anyone have a good example or documentation by hand?




Can you send us the crash report or describe your problems with the example application in more detail? Maybe we can find a solution together as the example is working for our environment setup.

Best regards


Hey :)

Thanks for the help! Of course I can get more detailed. First of, the project file (csproj) included .DS_Store files, which were not present within the downloadable example source code.

Error:  /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Cannot copy /Users/manuellaufenberg/Downloads/wikitude-xamarin-master/source/samples/Android/WikitudeSampleAndroid/Assets/samples/3_Point$Of$Interest_2_Poi$With$Label/.DS_Store to /Users/manuellaufenberg/Downloads/wikitude-xamarin-master/source/samples/Android/WikitudeSampleAndroid/obj/Debug/assets/samples/3_Point$Of$Interest_2_Poi$With$Label/.DS_Store, as the source file doesn't exist. (WikitudeSampleAndroid)

After removing these files fro the csproj, I still have an error preventing me from compiling:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Error executing task LinkAssemblies: Sequence contains no matching element (WikitudeSampleAndroid)

Also there are about 70 warnings, which I sadly can not copy paste at once. If you need them though, I'll try to get them somehow.

Any help? :) I tested it on my mac with Xamarin Studio as well as on my Windows Rig with VS 2012. Both have the same issues.

Cheers! :)

Since we launched the Xamarin Binding only a few days ago the topic Xamarin is somehow new for us as well. I will forward your problem to our Android developer, let's see what he can say about this error.

Best regards


Thanks a lot! :)

I'm really looking forward to work with Wikitude.

Best Regards,


You are right about the .DS_Store files which should not be there, I will upload a new version of the sample application as soon as possible.

However, I deleted the files from my machine, then opened the project in Xamarin Studio, removed them from the project, and had no problem with the build process. I didn't open the csproj file directly. I think it's the easiest way to resolve this issue. Please try doing the same, and let me know if it worked.

Heya :)

First of all, thanks for your help!

I tried what you've told me. However, I'm still having the / an error:

C:Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(5,5): Error MSB4018: Unerwarteter Fehler bei der LinkAssemblies-Aufgabe.

System.InvalidOperationException: Die Sequenz enthält kein übereinstimmendes Element.

   bei System.Linq.Enumerable.First(IEnumerable`1 source, Func`2 predicate)

   bei MonoDroid.Tuner.PreserveApplications.PreserveTypeProperty(CustomAttribute attribute, String property)

   bei MonoDroid.Tuner.PreserveApplications.ProcessAttributeProvider(ICustomAttributeProvider provider)

   bei MonoDroid.Tuner.PreserveApplications.ProcessAssembly(AssemblyDefinition assembly)

   bei Mono.Tuner.SubStepDispatcher.DispatchAssembly(AssemblyDefinition assembly)

   bei Mono.Tuner.SubStepDispatcher.BrowseAssemblies(IEnumerable`1 assemblies)

   bei Mono.Tuner.SubStepDispatcher.Process(LinkContext context)

   bei Mono.Linker.Pipeline.Process(LinkContext context)

   bei MonoDroid.Tuner.Linker.Process(LinkerOptions options, LinkContext& context)

   bei Xamarin.Android.Tasks.LinkAssemblies.Execute()

   bei Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()

   bei Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__20.MoveNext() (MSB4018) (WikitudeSampleAndroid)


(I dunno how I could put that into code tags :/)


You got an idea?

Thanks !:)



Hi, I fixed the problem witn .DS_Store files, and had no problem building the test application again.

Please, try downloading the source code from github, and compiling it again. 

Hi Manuel Laufenberg, 

I am also working on Xamarin.Android using Wikitude SDK. Can you give your personal e-mail Id to me? Did you solve the problem that you were facing before?



Login or Signup to post a comment