Start a new topic

Xamarin Sample App Android not working

Xamarin Sample App Android not working



Using a clone of the sample app from GitHub, I opened the solution into Xamarin Studio.

I set the WikitudeSampleAndroid Components by right-clicking and adding the Wikitude SDK component.

I fix the compilation error in BasicArchitectActivity.cs:49 :

var config = new ArchitectView.ArchitectConfig (Constants.WIKITUDE_SDK_KEY);

so that it becomes:

var config = new StartupConfiguration(Constants.WIKITUDE_SDK_KEY);

I choose my device and launch in debug mode.

The menu starts correctly, but whenever I tap on a secondary entry, for example "1.1 Image on target", I have the message "com.wikitude.samples.BasicArchitectActivity not defined/accessible".

So it seems that the BasicArchitectActivity is not seen correctly from the SamplesListActivity.

Anyone has tried Xamarin recently?

Hi Thomas,
Have you already tried the example that is included in our Xamarin Component (available in the Xamarin Component Store)?

Best regards


Hi Andreas. Thanks for your reply.

I haven't tried the example inside the component, no. I installed the component using the Xamarin component store by right-clicking on the "components" folder of the GitHub, as explained in the Xamarin component's Getting Started page.

So I have now a new Sample App in the sample/components/wikitude/samples or something like that?

Unfortunately, I have been re-aimed on another project, so I don't have time to investigate at the moment. I will come back to it as soon as possible.

If you install the component from the Xamarin Component Store, the sample is located in the sample folder. It loads a simple tracking example with an image augmentation.

Our samples on GitHub are not maintained as we moved everything into the component.

Best regards

Login or Signup to post a comment